gil0331

History

Member for
5 years 4 months
Submitted by gil0331 on Sun, 2017 Dec 10 - 04:12

Guys the iOS app needs to be updated so it can work with iOS 11 otherwise you cannot use it on the newest version of iPhone